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QuickBooks 2006 Network Installation FAQs 
 
The biggest change with QuickBooks® 2006 is that it is built on top of a robust SQL database. 
This new database will enable us to deliver significant performance and functionality 
improvements year over year.  However, the process for how company files are accessed by 
QuickBooks 2006 differs from prior years, and the following FAQs are designed to make sure 
you have the information and resources you need to optimize for this new environment. 
 
While file server issues are limited, they generate many of your questions. Therefore we start this 
list of FAQs by addressing file-server installations, as taken from the new Web site 
 
 
 

FAQs 
 

Why do I need to install QuickBooks on my data-only file server? 2 
Does QuickBooks need to be running on the data-only file server toaccess a company 
     file from another computer? 2 
Do I need to buy a license for the data file server copy of QuickBooks? 2 
How do I make sure that the data-only file server is properly set up to manage company 
     files? 3 
I have installed QuickBooks 2006 on my file server. Do I need to open every data file 
     on my file server before remote users can access them? 3 
How do I install QuickBooks on my network where multiple computers are running  
     QuickBooks and each computer has its own set of data files? 4 
Do all of the computers need to be on the same release version (e.g., R2, R3, etc.)? 4 
QuickBooks asks me if I want to open the company file in “Alternate” mode.  
     What is this? 4 
Why don’t you recommend the Alternate Mode? 5 
Performance on QuickBooks 2006 seems slower than it was in QuickBooks 2005.  
     What can I do to improve performance? 6 
I followed the instructions for opening a data file on the server, but I’m still getting  
     an error message when I try to open the data file from my remote computer. 7 
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Why do I need to install QuickBooks on my data-only file server? 
 
If you designated one computer to hold company files only, even though that computer is not 
used for data entry, you should install QuickBooks on that computer (this is a change from 
previous versions of QuickBooks). 
 
The QuickBooks 2006 software includes a database manager, which is a software component 
that manages QuickBooks company files. The database manager is responsible for managing 
users who are working in a company file, including users who are accessing the file from a 
remote computer. Users communicate with the database manager, and the database manager 
communicates with the company file, making sure that data is verified before it is saved. 
 
Any QuickBooks company file that is opened in version 2006 must be linked to, and hosted by, a 
database manager. Because all the communication between the user and the data file takes place 
through the hosting database manager, QuickBooks works smoothly and efficiently when the 
database manager is installed on the same computer as the company files. 
 

Does QuickBooks need to be running on the data-only file server to 
access a company file from another computer? 
 
After installing QuickBooks 2006 on a data-only file server and turning on the hosting, you do 
not have to open QuickBooks on the server in order to let remote users access the files stored on 
that computer from another computer. Only the other computer, the one being used by a 
QuickBooks data entry person, needs to be running QuickBooks 2006. 
 
When you install QuickBooks 2006, and configure the software to host users from remote 
computers (see the FAQ, “How do I make sure that the data file server is properly set up to 
manage company files?”), the QuickBooks database manager is configured to run automatically, 
without the need to open QuickBooks. This function is technically called “Running as a 
Service”, and it means that Windows runs the database manager automatically when you start the 
computer. 
 

Do I need to buy a license for the data file server copy of 
QuickBooks? 
 
If you are not going to use the computer on which the data files reside for QuickBooks data 
entry, you do not need to buy a license for the software. When you use a data file server, data 
entry is performed by users working at remote computers that are running licensed copies of 
QuickBooks. 
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How do I make sure that the data-only file server is properly set up to 
manage company files? 
 
You must configure QuickBooks as the host of the data files that are on the data-only file server. 
After you install QuickBooks, open the software and enable the Multi-User hosting function by 
selecting File > Utilities > Host Multi-User Access. This configures QuickBooks 2006 as the 
host for all QuickBooks 2006 data files on the computer. 
 
In addition, you must make sure that users have sufficient permissions to work with the data 
files, which is the same requirement that exists in previous versions of QuickBooks (as well as 
all software data files). Create a folder for your QuickBooks 2006 data files and share it, making 
sure that you set permissions that enable all users to save data. See the QuickBooks 2006 
Network Installation Guide (available from http://www.quickbooks.com/support/networking) to 
learn how to set permissions and set security. 
 

I have installed QuickBooks 2006 on my file server. Do I need to open 
every data file on my file server before remote users can access 
them?  
 
No. QuickBooks may prompt you to do this if you have attempted to open a data file on the file 
server from a remote computer that has not been accessed through the Database Manager. 
 
This request is generally the result of not having the level of permissions that QuickBooks 
requires. On the computer that holds the data file(s), you should have a local user account for 
every user who accesses the file from another computer. That local user account must be 
configured for Power User permissions (or higher). As an alternative, you can also create a local 
Power User and have all users log in to the computer holding the files with that user name, 
instead of creating user names for all your network users on that computer. Details about 
executing these tasks are available in the Installation Guide and Technical White Paper available 
from http://www.quickbooks.com/support/networking. 
 
If you prefer not to use Power User permission levels, you can open each data file on the file 
server. This automatically creates a small file linked to the company file, and the database uses 
that small file to enable remote users to work on the company file. You only need to open the file 
once (with some rare exceptions). 
 
However, this approach could be quite cumbersome for an accounting firm that accesses multiple 
data files. As a result, Intuit has a utility that creates the small file automatically for every file in 
the QuickBooks 2006 data file folder. This means you don't have to open QuickBooks and open 
each file. You can download the utility from 
 
http://www.quickbooks.com/support/networking 
 
 

http://ww
http://www.quickbooks.com/support/networking
http://www.quickbooks.com/support/networking
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How do I install QuickBooks on my network where multiple 
computers are running QuickBooks and each computer has its own 
set of data files? 
 
If you have multiple computers on your network that house QuickBooks data files, merely install 
QuickBooks on each computer. If users on other computers need to access any of the files on the 
computer, configure the QuickBooks software for multi-user access. After you install 
QuickBooks, open the software and enable the Multi-User hosting function by selecting File > 
Utilities > Host Multi-User Access. This configures QuickBooks 2006 as the host for all 
QuickBooks 2006 data files on the computer, including users who access the files from remote 
computers. 
 
It is possible (and common) for QuickBooks users to store data files on their own computers, but 
occasionally need to access data files that are on another computer. This works the same way it 
did for previous versions of QuickBooks, as long as the QuickBooks 2006 software is configured 
for multi-user hosting. 
 
 

Do all of the computers need to be on the same release version (e.g., 
R2, R3, etc.)? 
 
Yes, this hasn’t changed from previous versions of QuickBooks. When an update to QuickBooks 
2006 is released, you should update all the computers that are running QuickBooks 2006. 
QuickBooks makes it easy to update all the computers on the network by offering a shared 
download function that lets remote computers install updates from a single computer that has 
already downloaded the update instead of going online. 
 

QuickBooks asks me if I want to open the company file in "Alternate" 
mode. What is this? 
 
The Alternate mode is in contrast to the Recommended mode of installation. You see this 
message when you try to open a data file on another network computer, and that computer is not 
configured for hosting QuickBooks data files. It tells us that no QuickBooks database manager is 
controlling this file. This could mean that QuickBooks 2006 is installed on that computer, but the 
hosting mode has not been configured, or it could mean that the file is on a computer that is not 
running QuickBooks. 
 

• The Other Network Computer Has QuickBooks 2006 Installed. If the computer has 
QuickBooks 2006 installed, open QuickBooks on that computer and configure Hosting 
Mode by choosing File > Utilities > Host Multi-User Access. This enables the database 
service, and hereafter the file will open normally from a remote computer. 
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• The Other Network Computer Does Not Have QuickBooks 2006 Installed. If the 
computer does not have QuickBooks 2006 installed, you should install it. If nobody is 
using QuickBooks on that computer (that is, you are installing the QuickBooks software 
solely to manage the data files on that computer), you are not required to buy a license for 
the software. 

 
 
Note on Operating Systems. If you serve your company files from a Novell or Linux file server 
we STRONGLY recommend that you set up a Windows machine to service your company files 
for QuickBooks 2006. Otherwise no SQL database server, including the one in QuickBooks, can 
deliver appropriate levels of performance or reliability accessing the database across a network. 
For more information the Alternate Mode, see the technical White Paper at  
 
http://www.quickbooks.com/support/networking 
 
 

Why don’t you recommend the Alternate Mode? 
 
The following table outlines the benefits of the Recommended Mode and identifies the problems 
that could arise with the Alternate Mode. 
  

Feature  Recommended Setup  Alternate Setup  

Company files available at all 
times  

Yes  In some cases  
Depends on availability of 
users’ computers 

1
 

Reliable connection to 
company files  

Yes  In some cases  

Possible connection errors 
2
 

Fast performance  Yes  No  
More network 
communication means 
slower performance  

 
1 

In the alternate setup, a user’s computer is used to host the database server, while the files themselves exist on 
another computer. That user cannot turn off his or her computer or log out of Windows. Doing so will disrupt access 
to the company file for all QuickBooks users.  
2 

In the Alternate Setup, communication is more prone to network transmission errors. If errors occur when data is 
being transferred over the network, you will receive a connection lost error and QuickBooks will shut down. In 
QuickBooks 2006 R2 release and earlier, these connection errors were known as error 99937.  

http://www.quickbooks.com/support/networking
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Performance on QuickBooks 2006 seems slower than it was in 
QuickBooks 2005. What can I do to improve performance? 
 
Data files running in QuickBooks 2006 are larger than files running in previous versions, due to 
the additional features and functions of the QuickBooks database and database manager. 
However, the increase of file size will not ordinarily affect performance in QuickBooks 2006. 
 
Any of several reasons can affect the speed of your work in QuickBooks, whether the problem is 
that QuickBooks takes a long time to open, or that certain activities (such as creating reports) 
take longer when you’re working across the network. You can alleviate some of the problems by 
making sure your computers and network are properly configured. Recent tracking shows that 
the first two items below drive a majority of support calls on network installations. 
 

• Alternate Installation. Alternate Installations (see above) make themselves known 
through error messages and can also be detected by the following method: Within 
QuickBooks go to File > Utilities. Check to see if Multi_User Hosting is enabled. If you 
determine you have an Alternate Installation, refer to the Web site 
(http://www.quickbooks.com/support/networking) for the Technical White Paper or call 
Technical Support.  

• Firewall. Some software firewalls can cause QuickBooks to open slowly. (ZoneAlarm 
has been identified as one of firewalls that cause this problem.) If you determine you 
have a performance issue related to firewall software, check the Web site for any recent 
tips or call Technical Support. 

 
Other causes could be as follows: 
 

• Processor speed. Your processor should be rated for at least 500 MHz, and 1 GHz or 
more is better. (Right-click My Computer and select Properties to see the speed of your 
processor.) 

• Memory. You should have at least 512MB of RAM, and more is always better. (Right-
click My Computer and select Properties to see how much RAM is installed in your 
system.) 

• Paging File. Your paging file (often called a swap file) should be large enough to 
manage swapping of data that’s in memory without delay. A paging file is a disk-based 
file that Windows creates and uses as if it were RAM. To make sure your paging file has 
enough room, keep at least 20-25% of your hard drive space free. One way to keep free 
space on your drive at an optimal number is to delete temporary Internet files regularly, 
using the Tools menu of your browser. (If you’re comfortable with Windows technology, 
you can increase the size of the paging file; but if you don’t know what you’re doing you 
can damage your computer’s overall performance, so call in a consultant.) 

 
If performing tasks across the network seems slower than in previous versions of QuickBooks, 
you may also want to check the following parameters: 
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• Cabled connection speed. If you’re using Ethernet cable, be sure you’re using 100MB 
NICs and connection devices (router, hub, or switch). Some older computers have NICs 
that transmit data at 10MB, but 100MB NICs are inexpensive and easy to install. If 
you’re using a hub, invest in a switch, which transfers data faster. A hub receives data 
and transmits it to all computers on the network, splitting the bandwidth (transmission 
speed) among all ports. Only the computer that’s the intended receiver accepts the data; 
the other computers ignore it. A switch checks to see the intended recipient, and devotes 
all the bandwidth to the transmission of data directly to the recipient. (If you’re using a 
router as a connection device, it has a switch, not a hub.) If you’re using PowerLine or 
PhoneLine connections, there isn’t much you can do to improve the transmission speed. 

• Wireless connections speed. Wireless transmissions are slower than cabled networks, 
but you can often improve speed by making sure you’ve eliminated sources of 
interference. Don’t have a cordless telephone system that operates in the same MHz 
range anywhere near a wireless device, and make sure no metal objects (file cabinets, 
metal desks, metal pipes in walls, etc.) are interfering with transmission. If they are, 
consider switching those computers to cable. Install an Access Point to strengthen signals 
between devices that are far apart. (The best way to use an Access Point efficiently is to 
position it as high as possible—hanging it from the ceiling is a good idea.) Run a test to 
see whether NICs with a directional antenna will work better than the standard 
omnidirectional antenna. Keep the office microwave oven away from any network device 
(another source of MHz-channel interference). 

• Technical specifications of the computer that holds the data. Be sure a data file server 
is equipped with a fast processor, extra RAM, and plenty of free space on the hard drive. 
If possible, don’t use that computer for any other tasks, such as running other software 
applications. 

 

I followed the instructions for opening a data file on the server, but 
I’m still getting an error message when I try to open the data file from 
my remote computer. 
 
Use the following check list to try to resolve the problem. If none of these suggestions work, call 
QuickBooks support. 
 
Check the Basics 
 

• Is the data file server computer running? Did Windows launch successfully? 
• Is the data file server computer configured for Windows File Sharing? 
• Is the firewall on each computer configured properly for network access? If you’re using 

the built-in Windows XP firewall, and you haven’t upgraded to Service Pack 2 (SP2), 
you cannot run the firewall on a network. If you’re using the SP2 firewall, make sure that 
it’s configured for operating in a network. If you’re using a router-based firewall, turn off 
individual computer firewalls, or vice-versa, to avoid any chance of technology clashes. 

• Is the folder that holds the QuickBooks 2006 data files shared, and are permissions 
configured to let remote users access the files in that folder? 
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Check QuickBooks Error 
 

• Did the error message specify a reason and/or an error code? Check the QuickBooks 
support Web pages for the specific error. Start at the Web Page for Network or Multi-
User Installations of QuickBooks 2006, located at 
http://www.quickbooks.com/support/networking.  

• Can the file be opened directly from the server computer? If not, the file may be corrupt. 
Check the QuickBooks support Web pages for information about fixing corrupt files. See 
if a restoring a backup file works (the last backup may be corrupt if the current file is 
corrupt, so use a previous backup). If the file opens normally on the server, check your 
connectivity with the server, as follows: 

o Is the mapped drive displayed in My Computer as a connected drive? Double-
click the mapped drive to make sure your computer can access that folder. 

o Is the mapped drive displayed in My Computer as a disconnected drive? Double-
click the mapped drive to see if you can reconnect the drive. If you can’t, try re-
mapping the drive. 

o Can you access the folder that holds the file by navigating through My Network 
Places? If not, make sure the folder is shared and configured for appropriate 
permissions. 

• Can another file in the same folder (e.g. a QuickBooks sample company file) be opened? 
If so, the company file that produced the error may be corrupt. If not, the QuickBooks 
installation may have problems. Check for permissions issues for the software, the 
database manager, and the QuickBooks user that is installed. (Search the QuickBooks 
support Web pages for the level of permissions required.) 
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